Forum: bugs

Monitor Forum | Start New Thread Start New Thread
RE: Segfault [ reply ]
By: Manos Tsagias on 2008-12-03 12:41
Same here. very long MySQL extended inserts make perl to generate a segmentation fault.

I am using Perl 5.8.8.

The offending regex should be at line 868:
( $insert_table, $valueString) = $_ =~ m/^INSERT\s+INTO\s+['`"]*(.*?)['`"]*\s+VALUES\s*(.*)/i;

any ideas how to fix that?


RE: Segfault [ reply ]
By: Steed Mandabarino on 2008-06-23 18:37
Sorry, just found the other segfault thread and tried with --skip-extended-insert. Still segfaults but a bit further through:

INSERT INTO `posts` VALUES (258,80,9,1,1107633047,'\r\n\r\nmost bb code is borked urls work if you leave them on their own',0,NULL,'yes');

gets to

INSERT INTO "posts" VALUES (258,80,9,1,1107633047,E'\r\n\r\nmost bb code is borked urls wo

Again, tested on windows xp and gentoo.

RE: Segfault [ reply ]
By: Steed Mandabarino on 2008-06-23 18:24
Having a similar problem here. Running agains my DB export causes a seg fault but I can't see anything obvious that might be causing it.

I've run against a mysqldump on windows XP and (using the same DB) a mysqldump on a gentoo box. Both error in exactly the same place in the creation of the pg.sql. When I run with debug on I get this:

-- PRIMARY KEY (id),
primary key ("id"),
-- KEY topic_id (topic_id),

The offending mysql dump looks like this:
SET character_set_client = @saved_cs_client;

Happy to provide further info if required

Segfault [ reply ]
By: Ken Johanson on 2008-01-04 08:06
I am getting a perl (v5.8.8) segfault which I've determined is caused by an insert stmt that contains a large number of sequential apos ('). If I redeuce the number of apos the segfault doesnt occur, however the data export does indded contain/require these. If you email me at 'ken2006 at' I can send the cuplrit insert stmt.

Powered By FusionForge