Forum: libpqxx point releases

Posted by: Jeroen Vermeulen
Date: 2013-01-21 06:57
Summary:libpqxx point releases
Project:The libpqxx Project

Three new minor updates are available for download: 3.0.3 for the 3.0 series, 3.1.1 for the 3.1 series, and 4.0.1 for the 4.0 series. Get them at the download page:

https://pqxx.org/development/libpqxx/wiki/DownloadPage

Most of the changes are for compatibility with newer compilers, C++11, and different operating systems.

It's hard to make guarantees with C++, but you may find the binaries compatible with their respective previous versions. It is recommended that you use the 4.0.1 version where possible; the older versions will have problems with changes in more recent PostgreSQL versions.

The updates also include support for the REPEATABLE READ isolation level. This is the new name for the old SERIALIZABLE level. Newer PostgreSQL backends have a new, fully standards-compliant implementation for SERIALIZABLE. If your binary uses the old SERIALIZABLE isolation level and you re-link it to a newer libpqxx, without recompiling, it will get REPEATABLE READ on newer backends; behaviour will be identical to what the application was originally written for. Or if you recompile the program against a newer libpqxx, it will get the new fully-compliant SERIALIZABLE isolation.

Sponsors Ads

Latest News

libpqxx point releases

Jeroen Vermeulen - 2013-01-21 06:57 -

libpqxx 4.0 released

Jeroen Vermeulen - 2011-11-27 12:38 -

libpqxx 3.1 released

Jeroen Vermeulen - 2010-02-24 21:13 -

libpqxx 3.0.2

Jeroen Vermeulen - 2009-08-18 23:51 -
Monitor Forum | Start New Thread Start New Thread
Sap Sydney [ reply ]
By: theweb academy23 on 2013-01-23 05:27
[forum:1020494]

02bottom_logo.gif (3) downloads
SAP training Sydney courses offered by the webacademy are excellent and worth the money spent. Do make it a point to attend SAP training while visiting Sydney.

Powered By FusionForge