SCM

[#1010946] Connection Pooling -- doesn't seem to work

View Trackers | Bugs | Download .csv | Monitor

Date:
2010-11-21 19:34
Priority:
3
State:
Open
Submitted by:
Leo and Regina Hsu and Obe (lr1234567)
Assigned to:
Nobody (None)
Npgsql Version:
2.0.10
Category:
Group:
Resolution:
None
Summary:
Connection Pooling -- doesn't seem to work

Detailed description
This is actually for 2.0.11 but that wasn't an option in the drop down. We just upgraded to PostgreSQL 9.0 Windows 64-bit and replaced our driver with the newest.
In our ASP.NET 2.0 web application (32-bit), we had connection pooling enabled

With it enabled we get this error

"Timeout while getting a connection from pool. "

On rare occasions it works. We tried to increase the Timeout setting, but that did not help.

Having pooling=false works.

Just wondering if others are having similar issues or if its just us. Our older application on PostgreSQL 8.4 32-bit windows works fine with connection pooling on, but its using a much older npgsql driver. haven't tried replacing the driver on that one yet.

Thanks,
Leo and Regina

Followup

Message
Date: 2011-01-01 21:18
Sender: Francisco Figueiredo jr.


I added the 2.0.11 option. Sorry for that.

About your problem, is your current app closing all connections after using them even in a event of a problem?

Also, you may be getting more simultaneous users than 20 which is the default of maxpoolsize. Did you try to increase it?

I hope it helps.
Date: 2010-12-22 22:41
Sender: Josh Cooley

This happens by design when you use up all the connections in the pool. If you aren't cleaning up your connections then you have to wait on the GC. I imagine a 64-bit app may wait a bit longer between garbage collections and expose a latent bug in the app. If you have a sample app that reproduces this we'll have a better shot at looking for a bug in Npgsql pooling.

Attached Files:

Changes:

No Changes Have Been Made to This Item

Powered By FusionForge