SCM

[#1011094] can't build with PG 9.1

View Trackers | Bugs | Download .csv | Monitor

Date:
2011-09-21 22:48
Priority:
3
State:
Open
Submitted by:
Rad Cirskis (nad2000)
Assigned to:
Nobody (None)
Category:
Group:
Resolution:
None
 
Summary:
can't build with PG 9.1

Detailed description

make output:

....
....
parser_function.c: In function ‘FunctionParserInit’:
parser_function.c:277:31: error: macro "InitFunctionCallInfoData" requires 6 arguments, but only 5 given
parser_function.c:276:2: error: ‘InitFunctionCallInfoData’ undeclared (first use in this function)
parser_function.c:276:2: note: each undeclared identifier is reported only once for each function it appears in
make[1]: *** [parser_function.o] Error 1
make[1]: Leaving directory `.../postgresql-9.1.0/contrib/pg_bulkload-3.1.0/lib'
make: *** [all] Error 2




Followup

Message
Date: 2011-09-29 13:58
Sender: Arnaud LACOUTURE

This patch is working for me ( PG 9.1.1 ) ... Haven't tested yet any bulk import ... but compilation is OK

Thanks a lot
Date: 2011-09-29 01:07
Sender: Rad Cirskis

quick patch to make it compile tested with PostgreSQL 9.1.0
(build and BINARY, CSV data load)
Date: 2011-09-28 06:23
Sender: Arnaud LACOUTURE

Exactly same error with PostgreSQL 9.1.0 & 9.1.1

Seems that pgBulkLoad isn't compatible with the new extension system introduced with PostgreSQL 9.1.0

Attached Files:

Attachments:
pg_bulkload-3.1.0_pg9.1.patch

Changes:

Field Old Value Date By
File Added689: pg_bulkload-3.1.0_pg9.1.patch2011-09-29 01:07nad2000
Powered By FusionForge