[#1011219] cc1: error: unrecognized command line option "-arch" on mac os x 10.7

View Trackers | Bugs | Download .csv | Monitor

Date:
2012-08-25 03:09
Priority:
3
State:
Open
Submitted by:
Sureeraya Limpaibul (sureeraya)
Assigned to:
Nobody (None)
Category:
Group:
Summary:
cc1: error: unrecognized command line option "-arch" on mac os x 10.7

Detailed description
Dear Sir,

I'm try to build pljava.so on mac os x 10.7 (lion) with gcc 4.2 java 1.5.0_30
but got this error. Please help


bash-3.2# cd pljava-1.4.3/
bash-3.2# make
make[1]: Nothing to be done for `all'.
make[1]: Nothing to be done for `all'.
/u01/app/pgsql/pljava/src/pljava-1.4.3/src/C/pljava/Makefile:225: warning: overriding commands for target `pljava.so'
/Library/PostgreSQL/8.4/lib/postgresql/pgxs/src/makefiles/../../src/Makefile.shlib:365: warning: ignoring old commands for target `pljava.so'
gcc -no-cpp-precomp -c -isysroot /Developer/SDKs/MacOSX10.4u.sdk -mmacosx-version-min=10.4 -headerpad_max_install_names -arch ppc -arch i386 -Wall -Wmissing-prototypes -Wpointer-arith -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing -fwrapv -I. -I/Library/PostgreSQL/8.4/include/postgresql/server -I/Library/PostgreSQL/8.4/include/postgresql/internal -I/usr/include/libxml2 -I/usr/local/include/libxml2 -I/usr/local/include -DPKGLIBDIR=\"/Library/PostgreSQL/8.4/lib/postgresql\" -I/u01/app/pgsql/pljava/src/pljava-1.4.3/src/C/include -I/u01/app/pgsql/pljava/src/pljava-1.4.3/build/jni -DPGSQL_MAJOR_VER=8 -DPGSQL_MINOR_VER=4 -DPGSQL_PATCH_VER=12 -I/System/Library/Frameworks/JavaVM.framework/Headers/ /u01/app/pgsql/pljava/src/pljava-1.4.3/src/C/pljava/Backend.c -o Backend.o
cc1: error: unrecognized command line option "-arch"
cc1: error: unrecognized command line option "-arch"
make[1]: *** [Backend.o] Error 1
make: *** [c_all] Error 2

Followup

No Followups Have Been Posted

Attached Files:

Changes:

No Changes Have Been Made to This Item

Powered By FusionForge